But does not contain package github.com/labstack/echo/v4.1.14

Hi all
I am trying to install labstack as follows:

go get -u github.com/labstack/echo/v4.1.14

and got error message:

go get github.com/labstack/echo/v4.1.14: module github.com/labstack/[email protected] found (v3.3.10+incompatible), but does not contain package github.com/labstack/echo/v4.1.14  

What is wrong?

Thanks

You should get the dependencies from just

go get -u github.com/labstack/echo/v4

However if you wanted to get a specific version

go get -u github.com/labstack/echo/[email protected]

Actually, including the version number doesn’t seem to work at all, and the code on https://echo.labstack.com/guide is broken.

import "github.com/labstack/echo/v4" doesn’t work.

import "github.com/labstack/echo" does.