Error scanning github.com/labstack/echo/v4: cannot find package "." in


#1

We want to upgrade our echo version from v3 to v4. (And also do necessary fixes for any breaking changes.)
We use glide for package management.
while doing “glide up” that faced below error.

[ERROR]|Error scanning github.com/labstack/echo/v4: cannot find package “.” in:
/Users/nikunj.badjatya/.glide/cache/src/https-github.com-labstack-echo/v4

This is present in glide.yaml

-package: github.com/labstack/echo
version: ^4.1.7
subpackages:
-middleware

And imports looks like this

 "github.com/labstack/echo"
 "github.com/labstack/echo/middleware"

Using go version 1.12.7


#2

Anyone having any pointers on this issue ?
Anybody ?


#3

Any pointers guys ? ?