Using v3 or v4?

Greetings
I’m very new to Go and I’m trying to use Echo for my first project.

I’ve used the “Get started” guide and I found it is (it was?) using v3, like this:

	"github.com/labstack/echo"
	"github.com/labstack/echo/middleware"

Now I’m trying to add features, but it seems the docs moved to v4 and when trying to add them I see an error when running dep ensure:

Solving failure: No versions of github.com/labstack/echo-contrib met constraints:
	v0.8.0: Could not introduce github.com/labstack/[email protected], as it requires problematic packages from github.com/labstack/echo (current version v3.3.10):	github.com/labstack/echo/v4 is missing.	github.com/labstack/echo/v4/middleware is missing.
	v0.7.0: Could not introduce github.com/labstack/[email protected], as it requires problematic packages from github.com/labstack/echo (current version v3.3.10):	github.com/labstack/echo/v4 is missing.	github.com/labstack/echo/v4/middleware is missing.
	v0.6.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.5.2: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.5.1: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.5.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.4.1: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.4.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.3.1: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.3.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.2.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	0.1.0: Could not introduce github.com/labstack/[email protected], as its subpackage github.com/labstack/echo-contrib/jaegertracing is missing. (Package is required by (root).)
	master: Could not introduce github.com/labstack/[email protected], as it requires problematic packages from github.com/labstack/echo (current version v3.3.10):	github.com/labstack/echo/v4 is missing.	github.com/labstack/echo/v4/middleware is missing.

What am I missing? How can I use middlewares such as Jaeger?

Thanks in advance

Regards